it-swarm-id.com

Saya mendapatkan "The PHP Pustaka Tanggal/Waktu tidak didukung oleh Host web Anda. "Pada CentOS Host saya, perpustakaan apa yang harus saya instal untuk menambahkan dukungan?

Saya melakukan beberapa pencarian cepat-cepat, tetapi keterampilan PHP saya cukup baru. Saya yakin hanya ada paket yang perlu diinstal.

Edit untuk menambahkan informasi tambahan tentang pengaturan:

Menggunakan:

yum info php

Saya mendapatkan versi PHP sebagai 5.1.6:

Name       : php
Arch       : i386
Version    : 5.1.6

Informasi lebih lanjut, ini adalah VM menjalankan CentOS di GoDaddy:

CentOS release 5.4 (Final)
1
Larry Smithmier

Tingkatkan ke PHP 5.2 atau lebih tinggi

Pesan Kesalahan yang Anda lihat adalah oleh WordPress. Sangat menyesatkan apa yang pada dasarnya dikatakan, bahwa Anda memerlukan versi PHP = = 5,2 agar fitur itu berfungsi.

Silakan lihat dokumentasi sistem operasi Anda atau hubungi dukungan teknis tentang cara memperbarui versi PHP Anda. Untuk CentOS, misalnya: CentOS HowTos: PHP 5.1 Sampai 5.2

Tetap Perbarui Zona Waktu

Untuk mendapatkan hasil maksimal dari dukungan PHP Timezone , ada paket PECL yang berisi semua pembaruan terbaru: timezonedb .

Jadi di samping memutakhirkan PHP ke versi terbaru, Anda dapat menginstal paket PECL itu dan tetap memperbarui untuk mendapatkan pembaruan zona waktu terbaru (yang terakhir pada 16 Agustus):

$ yum install php-pear php-devel
$ pecl install timezonedb
3
hakre

wp-admin/options-general.php menampilkan pesan kesalahan berikut:

Sayangnya, Anda harus memperbarui ini secara manual untuk menghemat waktu siang hari. PHP Pustaka Tanggal/Waktu tidak didukung oleh Host web Anda.

Ini akan menampilkan blok kode tersebut jika fungsi-fungsi yang disediakan PHP berikut tidak ada:

Banyak fungsi-fungsi ini disediakan oleh keluarga kelas DateTime . Ini telah menjadi bagian dari inti PHP sejak versi 5.1/5.2, tergantung pada fungsi yang dimaksud. Meskipun saya benci untuk meminta klarifikasi dalam jawaban: Versi PHP apa yang Host Anda jalankan?

1
Annika Backstrom

Smithmier **:

PEMBARUAN: Saya melihat dari pembaruan Anda ini tidak berlaku untuk Anda tetapi itu akan berlaku untuk banyak orang lain dengan masalah Anda yang sama dan kami sedang mencari jawaban umum untuk pertanyaan yang berlaku untuk lebih dari satu orang saya akan meninggalkannya.


Saya berasumsi @hakre benar dan jika demikian dan jika Host web Anda menawarkan CPanel untuk Anda mengelola bit teknis akun hosting web Anda maka di sinilah Anda dapat mengubah versi PHP Anda:

Screenshot for PHP Configuration on CPanel
(sumber: mikeschinkel.com )

Yang kemudian membawa Anda ke layar ini yang merupakan tempat Anda dapat mengubah versi PHP Anda:

Changing your version of PHP on CPanel
(sumber: mikeschinkel.com )

1
MikeSchinkel