it-swarm-id.com

Migrasikan Pengguna, Izin, Akses, Grup, dan Konten dari 1.6 ke 3.3.X

Saya harus memperbarui instalasi joomla dari 1.6 ke versi baru, semoga 3.3.X. Saya telah bermain-main dengan proses peningkatan langkah demi langkah untuk beralih dari versi ke versi. Sejauh ini belum berjalan dengan baik.

Sebagai alternatif, saya berpikir untuk melakukan instalasi baru versi Joomla 3.3 baru jika ada cara untuk kemudian memigrasi konten dari instalasi 1.6 lama.

Adakah yang tahu cara untuk melakukan itu?

Memasang versi baru komponen dan ekstensi tidak akan sulit, tetapi saya perlu memindahkan semua pengguna, grup, tingkat akses, serta semua artikel dan menu. Tentu saja artikel dan menu perlu menjaga akses dan lokasinya agar benar agar semuanya berfungsi. Juga saya tidak mau harus mengatur ulang semua pengguna.

Terima kasih atas bantuannya!

3
jeffery_the_wind

Coba lagi migrasi langkah demi langkah:

Lakukan Backup terlebih dahulu lalu coba ini:

  1. Ikuti instruksi ini untuk Meng-upgrade Joomla 1.6.x ke Joomla 2.5.x - http://www.ostraining.com/blog/joomla/upgrade-joomla-16-to-25/
  2. Pastikan setiap komponen, plugin, template siap untuk Joomla 3.3
  3. Nonaktifkan plugin rememberme.
  4. Lalu pergi ke Joomla! Perbarui di bawah Menu Komponen, lalu klik tombol Opsi
  5. Ubah Pengaturan Pembaruan Server ke Dukungan Jangka Pendek dan simpan
  6. Kemudian Anda melihat Pembaruan Joomla terbaru dan Anda dapat memproses dengan cara biasa.
  7. Aktifkan plugin rememberme Anda.
3
Joomla Agency

Pertama-tama Anda harus memastikan Anda menjalankan Joomla 1.6.5 yang merupakan yang terbaru dari seri 1.6. Setelah selesai, buka Extensions (menu atas) >> pdate >> Purge Cache >> Find Updates.

Memperbarui menggunakan fitur pembaruan 1 klik seperti yang dijelaskan di atas akan secara otomatis memperbarui tabel basis data inti Anda, kode inti dan ekstensi inti. Jadi Anda tidak perlu khawatir tentang migrasi pengguna, izin dll.

Namun Anda mungkin perlu menginstal lebih banyak versi terbaru dari ekstensi pihak ketiga dan templat yang telah Anda pasang karena ada beberapa perubahan API mendasar sejak Joomla 1.6

Semoga ini membantu

2
Lodder