it-swarm-id.com

Kapan pindah ke rilis besar baru?

Dengan strategi pengembangan baru tidak akan ada versi yang disebut LTS dimuka. Dengan informasi yang saat ini diterbitkan 3.4 akan menggantikan 3.5 yang diumumkan. Dengan asumsi ada rencana untuk 4.0,4.1,4.2,4.3,4.4 pada waktu berapa situs diharapkan akan dimigrasi ke versi mana.

11
sovainfo

Ada beberapa hal yang perlu dipertimbangkan ketika merencanakan migrasi antar versi utama. Salah satu yang teratas adalah akhir dukungan atau tanggal EOL untuk versi yang Anda gunakan sekarang; jika itu dekat, Anda harus merencanakan langkah Anda.

Untuk situs web mapan, saya sarankan melihat fitur yang tersedia. Apakah versi baru memiliki sesuatu yang Anda butuhkan segera? Jika demikian, mulailah merencanakan migrasi Anda. Jika situs Anda berfungsi dengan baik dan tidak memerlukan fitur terbaru, Anda dapat tetap menggunakan versi saat ini selama masih didukung.

Jika Anda bermigrasi, seperti apa bentuk dukungan ekstensi itu? Apakah ekstensi yang Anda gunakan memiliki versi yang kompatibel untuk versi yang Anda migrasikan? Jika demikian, itu menyederhanakan banyak hal, tetapi jika tidak, berapa banyak usaha yang akan dilakukan untuk mengganti fitur mereka dengan sesuatu yang lain?

Akhirnya, setiap rilis yang ditandai sebagai stabil harus sesuai untuk dikembangkan, tetapi secara pribadi saya akan sedikit lebih berhati-hati dalam menggunakan rilis X.0 atau bahkan X.1 karena mereka biasanya lebih rentan terhadap bug yang diberi ruang lingkup perubahan yang bisa masuk ke rilis X.0 utama. Saya pribadi berpikir rilis X.2 atau X.3 adalah ketika Anda mulai melihat seri rilis matang sampai siap untuk penggunaan utama.

6
Michael

Mulai dari Joomla! 3.4 setiap versi akan menjadi versi yang stabil dan akan memiliki dukungan setidaknya dua tahun kecuali versi minor baru akan dirilis. Jika itu akan terjadi maka versi minor sebelumnya tidak akan didukung dan yang saat ini akan didukung setidaknya dua tahun. Jadi jika Anda berencana untuk bermigrasi ke seri 3.x, maka Anda aman melakukannya dari v3.4.

Hal yang sama berlaku untuk seri 4.x - 4.0 juga akan menjadi stabil dan akan memiliki dukungan setidaknya dua tahun kecuali versi minor baru akan dirilis (misalnya 4.1). Jadi, Anda dapat bermigrasi ke versi minor seri 4.x apa pun. Namun perlu diingat bahwa setiap rilis utama memiliki perubahan mundur yang tidak kompatibel! Jadi migrasi ini harus direncanakan dengan sangat hati-hati.

Tentu saja Anda tidak boleh bermigrasi ke rilis BETA atau RC, karena ini hanya untuk tujuan pengujian.

1
Dmitry Rekun

Dalam pemahaman saya, mulai dengan 3.4 Anda harus selalu menggunakan rilis terbaru, karena akan mendapatkan dukungan selama 2 tahun setelah rilis dan dukungan untuk versi yang lebih lama (3.3, ...) akan dihentikan. Semua rilis dalam satu seri (3.x) akan kompatibel mundur sehingga pembaruan umumnya tidak menjadi masalah.

Seri 4.x baru akan merusak kompatibilitas dan Anda hanya perlu memutakhirkannya jika Anda ingin menggunakan fitur-fitur baru.

0
fruppel
  1. Jika Anda memulai pengembangan, maka gunakan versi utama terbaru yang tersedia (Gunakan 4 seri bila tersedia)
  2. Ketika versi minor baru (3.4) dirilis, tunggu saat versi Anda saat ini (3.3) didukung. Pada saat itu versi baru harus telah menerima perbaikan bug penting. Jadi situs web Anda sekarang dapat diperbarui dengan aman.

Kiat: Selalu pertahankan situs uji dengan pengaturan server yang sama, untuk mengujinya terlebih dahulu, lalu gunakan versi tersebut.

0
Shyam