it-swarm-id.com

Mutakhirkan dari 2.5 ke 3.x ikhtisar

Ini adalah sesuatu yang saya ingin tahu untuk beberapa waktu mempertimbangkan beberapa hal.

Seberapa baik peningkatan "satu klik" akan meningkat sebelum EoL Joomla! 2.5?

Saat ini kami memiliki tingkat keberhasilan yang sangat rendah pada peningkatan dari 2,5, ada banyak masalah kompatibilitas yang tidak diselesaikan hanya dengan peningkatan dan memerlukan beberapa suntingan manual untuk menyelesaikan proses sebagian besar waktu (masalah dengan JHTML adalah yang paling umum saya. Lihat).

Sekarang saya mengatakan "masalah" tetapi saya hanya bermaksud bahwa setelah pembaruan hal-hal tidak berfungsi sebagaimana dimaksud, ini sama sekali tidak mengatakan bahwa komponen "pembaruan" rusak.

Saya telah melihat sekeliling tetapi hanya menemukan yang berikut:

http://docs.joomla.org/Joomla!_CMS_versions

http://developer.joomla.org/cms/roadmap.html

Negara pertama menyatakan bahwa dukungan untuk Desember 2.5 mendatang untuk 2.5 akan dibatalkan. Yang kedua menyatakan peta jalan untuk 3.x. Namun saat ini sangat sulit untuk memutakhirkan dari 2.5, semakin besar situs, semakin sulit. Saya tidak yakin apa yang menyebabkan beberapa berhasil dan beberapa tidak, dalam kebanyakan kasus kami tidak dapat mengisolasinya ke ekstensi pihak ketiga secara langsung (manajer ekstensi istirahat dan semacamnya dari tabel yang hilang, dan manajer ekstensi adalah tempat Anda memperbaikinya).

Di sinilah masalah sebenarnya muncul dengan peningkatan, jika situs menggunakan basis data besar-besaran dengan sesuatu seperti sobipro, k2 atau pembangun konten, atau hanya banyak artikel/modul maka peningkatan bisa gagal jauh lebih mudah. Itu tidak dapat dihapus, dinonaktifkan, atau dihapus instalasinya (mis: 4000+ item akan hilang dengan uninstall, pada titik itu mungkin juga membuat ulang situs lalu memutakhirkan).

Jadi, apakah ada rencana untuk meningkatkan pemutakhiran satu klik untuk 2,5 menjadi 3,x untuk mengakomodasi EoL dengan lebih baik? (seperti posting berita atau blog) Pertanyaan aneh tapi saya rasakan dengan berapa banyak 2.5 situs di luar sana yang tidak dapat memutakhirkannya bisa sangat berharga.

15
Jordan Ramstad

"satu klik" peningkatan bekerja sangat baik untuk Joomla! 2.5 Core.

Tetapi situs Anda mungkin memiliki beberapa templat atau ekstensi untuk ditingkatkan juga.

Saya juga merencanakan migrasi "Juni" dari situs utama kami. Ini rencanaku:

  • Cadangkan situs utama dan buat situs uji baru
  • Tinjau persyaratan sistem untuk Joomla 3.x dan pastikan bahwa lingkungan server Anda memenuhi persyaratan tersebut.
  • Instal dan sesuaikan Joomla baru! 2.5/3 templat yang kompatibel
  • Instal dan sesuaikan semua Joomla! 2,5/3 ekstensi yang kompatibel
  • Jika beberapa ekstensi tidak memiliki versi yang kompatibel J3, itu harus diganti dengan ekstensi baru .... DAN data harus dimigrasikan (skenario terburuk)
  • NOTE : Langkah-langkah sebelumnya dapat dijalankan secara off-line, teruji, dan pada akhirnya Anda dapat mengimplementasikannya pada saat ini Joomla! 2.5 situs untuk mengurangi risiko migrasi satu hari.
  • Perbarui situs pengembangan Anda dengan situs langsung terbaru
  • Langkah terakhir: peningkatan "satu klik" ke Joomla! 3 di situs pengembangan
  • Tes dan periksa semuanya sampai berfungsi OK
  • Migrasikan situs langsung (atau kembalikan snapshot situs pengembangan terbaru pada hosting baru .... untuk berjaga-jaga jika terjadi kesalahan, dan Anda harus mengaktifkan kembali situs J2.5)
  • SUKSES
11
Anibal

Untuk peningkatan dari 2,5 menjadi 3,3, saya lebih beruntung melakukan upgrade manual juga. Untuk versi, saya akan naik ke 2.5.20-> 3.0.3-> 3.1.6-> 3.2.4-> 3.3.0.

Ini adalah proses lengkap:

  1. Unduh semua versi itu dan unzip di mesin lokal (di sini ada sumber yang bagus: http://www.whitefirdesign.com/resources/joomla-release-archive.html )
  2. Cadangkan menggunakan Akeeba
  3. Buat situs klon dalam subfolder menggunakan Akeeba Kickstart (buat/gunakan basis data baru)
  4. Di backend situs web, copot pemasangan ekstensi "masalah" (lihat bagian bawah pos)
  5. Di FTP, unggah semua file dari versi Joomla baru kecuali folder/instalasi /.
  6. Di bagian belakang situs web, buka EXTENSIONS-> EXTENSIONS MANAGER-> DATABASE, dan tekan FIX
  7. Lalu pergi ke EXTENSIONS-> EXTENSIONS MANAGER-> DISCOVER, tekan temukan dan instal untuk apa pun yang ditemukannya
  8. Pergi ke ACL Manager (jika Anda tidak punya, saya sangat menyarankan) dan memperbaiki masalah ACL yang ditemukannya. http://aclmanager.net
  9. Ulangi proses dengan versi Joomla berikutnya

Setelah Anda mendapatkan versi terbaru:

  1. Instal ulang ekstensi "masalah"
  2. Cadangkan versi baru
  3. Situs uji untuk masalah
  4. Pindahkan situs asli ke dalam subfolder
  5. Pindahkan situs baru ke root untuk ditayangkan

Seluruh proses ini memakan waktu lama karena waktu unggah untuk versi lengkap, tetapi menghemat sakit kepala.

Untuk ekstensi masalah, ini hanya yang menyebabkan masalah selama peningkatan bagi saya. Hipotesis saya adalah bahwa paket instal sebenarnya memiliki versi yang berbeda untuk J2.5 vs J3.3 sehingga menjadi bingung ketika Anda memutakhirkan. Jika ada yang menemukan orang lain, beri tahu saya.

  • Ekstensi NoNumbers (NN Manager, Cache Cleaner, Adv Module Manager, Modul Anywhere, dll)

Ekstensi ini dapat menyebabkan masalah jika tidak menggunakan rilis terbaru:

  • RSForm
  • JW AllVideos
  • RokBox
  • RSForm
  • Bookmark Sosial
  • XMap
4
YellowWebMonkey

Saya tidak dapat memutakhirkan direktori dari 2.5.7 ke 3.2.0. Saya menemui berbagai kesalahan selama peningkatan ini, kadang-kadang tidak dapat memperbarui sama sekali.

Jalur peningkatan yang harus saya ambil sebagai:

2.5.7 → 3.0.1 → 3.1.5 → 3.2.0

Sejak itu saya sudah bisa melakukan upgrade secara normal. Saya sedang menjalankan 3.2.2 dan berencana untuk meningkatkan ke 3.3 segera.

3
ContextSwitch

Untuk menjawab pertanyaan utama:

Seberapa baik peningkatan "satu klik" akan meningkat sebelum EoL Joomla! 2,5?

Tidak ada rencana untuk memperbaikinya. Ini bekerja tanpa masalah untuk inti. Template harus diganti karena keluaran ekstensi yang berubah. Ekstensi lainnya perlu diperiksa secara manual, tergantung bagaimana mereka dibangun. Dimungkinkan untuk menulis ekstensi yang berfungsi pada 2.5.15+ dan 3.x dengan basis kode yang sama. Tetapi kita harus memeriksanya dengan mencoba atau dengan menghubungi pengembang (atau membaca FAQ mereka).

Satu-satunya hal yang dapat ditingkatkan di 2,5 adalah menambahkan pemeriksaan kompatibilitas pra-upgrade. Ada beberapa pekerjaan yang dilakukan untuk itu tetapi macet. Seseorang dari komunitas harus mengambil dan mengakhiri.

2
Bakual

Berikut adalah beberapa informasi bermanfaat yang saya temukan pada peningkatan.

Pertama, jika situs web awalnya dalam 1,6, kemudian ditingkatkan menjadi 2,5 lalu bahkan dalam versi terbaru 2,5 semua ekstensi masih akan berfungsi. Namun untuk meningkatkan ke 3.x membutuhkan menginstal ulang. Ini karena perbedaan dalam area "pembaruan" berarti bahwa jika 1.6, maka server pembaruan tidak akan membaca pembaruan dengan benar, jadi jika itu adalah komponen 1.6, setidaknya dalam banyak kasus (saya telah melihat ini di DJ Image Slider dan BreezingForms) tidak akan memperbarui setelah ditingkatkan ke 2,5.

Jadi upgrade manual dari ekstensi ini diperlukan di beberapa titik seumur hidup di 2.5. Saya percaya tergantung pada ekstensi mungkin ada masalah dengan pembaruan sql normal juga, tetapi hanya sesuatu yang harus diperhatikan.

Terkadang ekstensi dapat diubah namanya atau "diperbarui" yang akan menyebabkan Joomla kadang membacanya sebagai komponen baru, yang mengarah ke beberapa entri dari komponen yang sama, lama dan baru. Jika Anda menghapus satu itu masih menggunakan tabel database yang sama, jadi itu menghapusnya jika Anda sudah menginstalnya.

Ide: Jadi satu hal yang saya pikir akan berguna dalam hal ini adalah menambahkan ke manajer ekstensi untuk memeriksa ekstensi yang dimaksudkan untuk versi yang lebih lama, untuk membuatnya mudah terlihat, ini bisa dilakukan dengan melihat pembaruan "date" terakhir dan apakah sebelum perubahan potensial melanggar Joomla jika versi saat ini melewati versi itu.

Either way dalam kasus situs pergi dari 1,6 ke 2,5 kemudian ke 3.x pada titik mana pun dapat memaksa menginstal ulang yang karenanya akan menghapus data.

Gagasan lain: Jika "instal ulang" ditambahkan di samping pembaruan, gunakan melacak versi yang lebih lama dan server pembaruannya, atau url/unggah khusus untuk menghapus instal komponen pada dasarnya tanpa menghapus data. Kemudian instal ulang saat menggunakan pembaruan sql untuk memperbarui tabel database akan sangat berguna.

Saya menggunakan situs yang awalnya 1.6 karena akan menunjukkan masalah ini lebih sering, itu bisa terjadi dengan situs yang dimulai pada 2,5 juga.

Ini menjelaskan banyak masalah yang dapat muncul dari ekstensi yang mungkin belum pernah ditingkatkan untuk menambah kompatibilitas ke 3.x, plugin adalah yang terburuk karena bahkan di panel admin kesalahan dalam mereka dapat membuat panel admin tidak dapat digunakan.

Namun ide lain: Manajer pembaruan Joomla dapat secara otomatis menonaktifkan semua plugin pihak ketiga selain beberapa (seperti akeeba, karena melacak pembaruan) kemudian memperbarui. Setelah itu mengaktifkan kembali semua plugin lagi tetapi "memeriksa" plugin sistem untuk kesalahan. Yang saya maksud adalah itu otomatis memicu berbagai peristiwa dengan mencoba/menangkap untuk melihat apakah ada kesalahan, jika ada menonaktifkan dan memberi tahu.

Sekarang ini semua tidak mengasumsikan masalah inti, yang seharusnya tidak terjadi pada pembaruan.

Gagasan yang saya posting di atas dimaksudkan untuk tim pengembang, sisanya adalah informasi yang baik untuk semua orang memperbarui. Gagasan yang saya pasang bahkan harus dapat memungkinkan pembaruan tanpa menghapus/menonaktifkan ekstensi terlebih dahulu yang berpotensi tambahkan jauh lebih banyak pekerjaan ke dalam proses. Dengan beberapa tambahan pada updater yang sudah hebat, bahkan pembaruan otomatis penuh (seperti wordpress) dapat dilakukan di masa depan.

2
Jordan Ramstad

Prosedur yang saya gunakan telah berkembang lebih dari sekitar 40 migrasi mini Joomla 2.5 hingga 3.x yang beragam. Ini bukan "satu klik" tetapi membantu menghindari jebakan yang paling umum. Sebagian besar situs web yang saya rawat menggunakan templat RocketTheme dan ada versi yang setara Joomla 3.x dari templat Joomla 2.5 yang telah mengurangi masalah migrasi templat untuk saya tetapi jarak tempuh Anda mungkin berbeda-beda.

  1. Periksa lingkungan hosting cocok untuk Joomla 3.x

  2. Jalankan pencadangan dulu!

  3. Copot ekstensi apa pun yang tidak kompatibel dengan Joomla 3.x

  4. Perbarui ke Joomla 2.5.28 jika belum pada 2.5.28 dan perbarui semua ekstensi pihak ketiga ke versi Joomla 2.5 terbaru yang tersedia

  5. Nonaktifkan "System - Remember Me" plugin

  6. Nonaktifkan "System - Backup on update" plugin jika Akeeba Backup diinstal

  7. Dalam Konfigurasi Global, Atur Pelaporan Kesalahan ke "Pengembangan" (sehingga kesalahan terlihat setelah migrasi - jika Anda melewatkan langkah ini Anda mungkin harus menggunakan FTP dll untuk mengunduh configuration.php, edit untuk mengaktifkan pesan dan kemudian unggah versi yang diperbarui melalui FTP dll yang merepotkan)

  8. Ubah Komponen -> Pembaruan Joomla -> Opsi ke "Dukungan Jangka Pendek"

  9. Di Komponen -> Pembaruan Joomla, klik "Instal Pembaruan" untuk memperbarui dari 2.5.x ke 3.5.1, 3.5.1 hingga 3.6.5 dan kemudian 3.6.5 ke versi terbaru. Bersihkan cache Joomla dan bersihkan cache di Extensions -> Extension Manager -> Update, dan coba lagi jika pembaruan tidak ditawarkan. Anda mungkin harus mengautentikasi ulang satu atau dua kali saat pembaruan token sesi dilakukan

  10. Ubah Komponen -> Pembaruan Joomla -> Opsi -> Perbarui Saluran ke "Default" jika belum diatur ulang ke "Default"

  11. Instal ulang ekstensi Joomla 3.x terbaru di atas semua ekstensi yang diinstal terutama ChronoForms dan Tindakan ChronoForms jika Anda memiliki semua ini diinstal

  12. Bersihkan cache Joomla dan cache browser web Anda

  13. Dalam Konfigurasi Global, atur kembali Laporan Kesalahan ke "Tidak Ada"

  14. Aktifkan kembali plugin "System - Backup on update" jika Akeeba Backup diinstal

  15. Aktifkan kembali "System - Remember Me" plugin

  16. Nonaktifkan "System - Joomla! Update Notification" plugin untuk mematikan notifikasi pembaruan Joomla (opsional)

  17. Hapus templat Joomla 2.5 (atomic, beez5, beez_20, bluestork)

  18. Aktifkan kontrol versi di Konten -> Artikel -> Opsi -> Tata letak pengeditan jika sesuai (kontrol versi dinonaktifkan secara default)

  19. Nonaktifkan "Izinkan Registrasi Pengguna" di Pengguna -> Kelola -> Opsi -> Opsi Pengguna jika perlu (ini diaktifkan sebagai default di Joomla 2.5)

Langkah 11 adalah penting untuk memungkinkan skrip instalasi untuk melakukan langkah-langkah spesifik Joomla 3 apa pun yang mungkin belum dijalankan ketika mereka awalnya diinstal pada Joomla 2.5.

Ingatlah untuk memperbarui PHP versi jika sesuai. PHP 5.3 adalah akhir hidup dan PHP 5.6 atau PHP 7.0 atau yang lebih baru adalah pilihan yang lebih baik untuk Joomla 3.x sekarang.

1
Neil Robertson

Saya menemukan ada begitu banyak hal yang perlu dipertimbangkan dengan memutakhirkannya sehingga tidak dapat dianggap sebagai proses "satu klik".

Versi PHP adalah hal pertama yang harus dipertimbangkan. Versi Joomla juga ... selalu tingkatkan ke versi final di pohon apa pun sebelum naik tangga ke yang berikutnya. Gunakan Akeeba CMS Updater untuk memilih pembaruan yang ingin Anda terapkan dan dari cabang mana.

Ekstensi adalah tempat rambut menjadi benar-benar berbulu.

Menggunakan ekstensi seperti SP Transfer dapat mengurangi masalah dengan membuat situs sekunder yang dapat diinstal sebelumnya pada versi baru dengan semua komponen diinstal untuk versi itu dan kemudian menarik semua data yang diperlukan dari basis data melalui.

Proses ini bukan untuk pengguna sehari-hari umum sekalipun.

Lebih sering daripada tidak saya menemukan beberapa tingkat masalah dengan tabel aset dan biasanya harus menggunakan diagnosa ACL Manager untuk memperbaiki Orphan atau item yang hilang dalam tabel.

1
BodgeIT