it-swarm-id.com

Apa versi maksimum PHP yang akan dijalankan Joomla 1.5?

Saya punya klien dengan Joomla 1.5 lama yang tidak ingin mereka tingkatkan tahun ini tetapi Host mereka ingin memutakhirkan server. Apa versi maksimum dari php yang akan dijalankan Joomla 1.5 daripada min yang terdaftar?

http://www.joomla.org/technical-requirements.html#footnote-1xPHP
Joomla! versions 1.5.15 and later are compatible with PHP 5.3.

Apakah akan berjalan baik di 5.3.10? Saya kira itu akan rusak pada 5,4 tapi saya merasa sulit untuk membangun mesin uji dengan versi lama untuk menguji. Jadi lebih banyak pertanyaan dari pengalaman.

terima kasih

4
tristanbailey

Jika Anda menjalankan Joomla 1.5.14 atau di bawah maka Anda harus tetap menggunakan PHP 5.2 karena mungkin ada beberapa fungsi dan/atau cuplikan kode yang mungkin tidak berfungsi pada PHP 5.3

Namun, jika Anda menjalankan Joomla 1.5.15 atau di atas , Anda seharusnya baik-baik saja dengan memutakhirkan ke PHP 5.3. Jika Anda menggunakan pustaka OpenID, maka ini tidak akan kompatibel dengan PHP 5.3 dan karenanya Anda perlu mencari alternatif atau tetap menggunakan PHP 5.2

Untuk informasi lebih lanjut tentang versi PHP, MySQL dan Apache, lihat Persyaratan Teknis

Saya sarankan Anda meningkatkan ke Joomla 1.5.26 yang merupakan versi terbaru dari seri 1.5.

Semoga ini membantu

5
Lodder

Saya menjalankan situs Joomla 1.5.26 bersama situs J3 baru yang sedang dibangun pada instalasi PHP yang sama. Situs J1.5 berjalan dengan sempurna di PHP = 5.6 tanpa perubahan apa pun sama sekali. Situs J1.5 adalah situs yang sangat sederhana dengan hanya beberapa ekstensi.

4
biltong

Saya mengkonfirmasi Joomla 1.5.24 berjalan pada PHP 5.5.9-1ubuntu4.17. PHP-FPM diinstal dengan apt. Server web adalah nginx. Semua fitur tampaknya berjalan dengan lancar.

3
Egeshi