it-swarm-id.com

Galat memutakhirkan dari 2.9.2 ke 3.0.1

Saya telah menginstal wordpress di bawah svn. Saya berada di versi 2.9.2. Inilah langkah-langkah yang saya ambil:

  • menyimpan salinan direktori wordpress saya saat ini
  • cd ke direktori wordpress tingkat atas saya
  • svn up (hanya untuk memastikan bahwa saya memiliki yang terbaru dari 2.9)
  • svn sw http://core.svn.wordpress.org/tags/3.0.1/ . (peningkatan)
  • jalankan wp-admin/upgrade.php
  • mendapat kesalahan ini "Kesalahan fatal: Panggil ke fungsi is_multisite () di yang tidak terdefinisi (direktori instal saya) /wordpress/wp-include/wp-db.php pada baris 505"

Saya melihat sekeliling dan beberapa orang berpikir ini masalah memori dengan PHP. Jadi saya mencoba plugin Memory Bump dan itu tidak berhasil.

Ada ide?

Perbarui: Ditemukan pos ini . Unduh tar 3.0 terbaru dan timpa wp-settings.php saya dengan yang ada di unduhan.

Dapatkan kesalahan yang berbeda sekarang. "Kesalahan fatal: Tidak dapat mendeklarasikan ulang wp_load_image () (sebelumnya dinyatakan dalam /myinstalldir/wordpress/wp-includes/media.php://41) di/ myinstalldir /wordpress/wp-admin/includes/image.php on line 168 "

Ketika saya melakukan dan svn status saya melihat banyak bendera 'S' (diaktifkan). Apakah saya harus khawatir dengan itu? wp-settings.php memiliki flag itu.

Pembaruan: Inilah output dari svn sw di atas dari direktori root Wordpress.

Pembaruan: Output dari svn stdi sini . (Migrasi daftar panjang ke Pastebin)

Pembaruan: Output dari svn info

Path: .
URL: http://core.svn.wordpress.org/tags/3.0.1
Repository Root: http://core.svn.wordpress.org
Repository UUID: 1a063a9b-81f0-0310-95a4-ce76da25c4cd
Revision: 15559
Node Kind: directory
Schedule: normal
Last Changed Author: ryan
Last Changed Rev: 13165
Last Changed Date: 2010-02-15 09:38:59 -0800 (Mon, 15 Feb 2010)
1
milesmeow

Saya juga menggunakan SVN sebelumnya untuk memperbarui instalasi wordpress saya. Hingga pekerjaan yang disalin akan kacau dengan sangat cepat dengan semua pembaruan manual atau file yang dibuat oleh plugin.

Saya selalu merekomendasikan untuk menggunakan fungsionalitas pembaruan wordpress jika Anda hanya ingin melangkah dari satu versi yang ditandai ke yang lain.

Meskipun, saya juga menggunakan SVN untuk salinan wordpress lokal agar dapat dengan cepat menguji plugin saya di beberapa versi lama dengan cepat. Saya menggunakan Eclipse untuk beralih dari satu tag ke tag lainnya dan sampai sekarang berhasil. Tetapi Anda tidak akan pernah tahu.

PERBARUI: Saya baru saja mencoba untuk mengganti checkout bersih dari 2.9.2 ke 3.0.1 yang sepertinya berfungsi, tetapi saya hanya bisa melihat backend dan bukan frontend dari blog tunggal default.

PERBARUI: Apa yang bahkan mode debug tidak memberi tahu saya: Sebagai tema standar pra WP 3.0 tidak lagi tersedia Saya hanya perlu beralih ke tema "2010" yang baru. Sekarang semuanya berfungsi.

Jadi pergantian tidak bekerja, tetapi seperti yang saya katakan sebelumnya, copy pekerjaan Anda biasanya kacau dengan banyak file yang mungkin menyebabkan beberapa masalah memperbarui salinan WP Anda dengan sakelar SVN.

2
2ndkauboy

Kedengarannya seperti Anda menjalankan svn sw di subdirektori, bukan pada direktori WordPress tingkat atas. Kami mungkin dapat membantu Anda memulihkan, jika Anda tidak dapat hanya checkout salinan bersih dan beralih dari plugin dan tema Anda. Output lengkap dari svn st akan sangat membantu, juga svn info untuk direktori apa pun yang mungkin telah beralih terlepas dari induknya.

0