it-swarm-id.com

Apakah ada versi Joomla yang aman! 1,6 atau 1,7 tersedia?

Apakah ada versi aman apa pun dari Joomla lama! 1.6.x, atau seri 1.7.x tersedia?

7
JacquesR

Jawaban pendek dan panjang adalah tidak. Anda perlu memutakhirkan situs 1.6 atau 1.7 ke setidaknya 2.5.x karena itu adalah versi yang paling aman (meskipun 2.5 sudah mendekati akhir masa pakainya). Jika Anda memiliki templat yang kompatibel, Anda mungkin dapat meningkatkan ke 3.3.

7
Andrew Eddie

Setiap situs web Joomla dan untuk memperluas ini sedikit, segala jenis perangkat lunak, terutama yang open source dan yang terbuka untuk umum, harus terbaru, untuk memastikan keamanan maksimum.

Versi terpelihara Joomla saat ini adalah Joomla 2.5 dan Joomla 3.3. Joomla 1.6 dan 1.7 adalah rilis jangka pendek dan kita dapat mengatakan mereka seperti path dari versi 1.5 ke 2.5. Mereka tidak dimaksudkan untuk tinggal lama, mereka tidak dipertahankan (= tidak ada tambalan keamanan, tidak ada perbaikan bug, tidak ada dukungan ekstensi), sehingga mereka tidak dapat digunakan lagi pada produksi.

Pembaruan, terlepas dari kenyataan bahwa mereka dapat menambahkan fitur baru, mereka menangani kerentanan yang diketahui dan masalah keamanan. Kerentanan tersebut diketahui oleh publik, oleh karena itu versi perangkat lunak yang lebih lama dapat dengan mudah dikompromikan.

Syarat lain, yang harus kita perhatikan, adalah bahwa ekstensi pihak ke-3 juga tidak dikelola untuk versi yang lebih lama, memberikan lebih banyak ruang untuk kerentanan dan kemungkinan tidak kompatibel lainnya dengan perangkat lunak server.

Biasanya, meningkatkan dari 1,6, 1,7 ke 2,5 dan 3,3 adalah jenis tugas yang mudah. Tetapi perlu diingat bahwa ini tergantung pada kondisi spesifik dari setiap situs web, ekstensi pihak ke-3 dan tingkat penyesuaian yang mungkin dan

Sangat disarankan untuk tidak mencoba memutakhirkan langsung di situs web langsung, dan selalu menyimpan cadangan situs web yang berfungsi.

1
FFrewin